Manjaro Linux -Forum Italiano-

Schermo Nero all’Avvio –Utilizzare la Modalità Testuale(tty) spesso risolve.

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

D-BARTO

  • ****
  • 384
  • Rolling User
Può capitare,per qualche problema, spesso riconducibile ad aggiornamenti, che il nostro Manjaro non parta, avviandosi ma restando con schermo nero e non mostrando la schermata di login.
In questo caso particolare non allarmiamoci, ma tentiamo di risolvere la cosa utilizzando la modalità testuale.
In pratica è una modalità che permette di lavorare con manjaro come se stessimo lavorando da terminale.
-----------------------------------
Quindi se Manjaro, ha in avvio, qualche problema, entriamo in modalità testo premendo contemporaneamente  i tasti
Ctrl+Alt+F2 ( vanno tutti bene i tasti funzione F1-F6)
fatto questo il sistema ci chiederà di inserire il nostro username e la nostra password e da qui in poi potremmo impartire tutti i comandi che vogliamo per tentare ripristinare il corretto funzionamento del sistema.
-------------------------------------
-Nel caso specifico, di schermo nero all'avvio verificatosi dopo un aggiornamento.
Facciamo partire Manjaro normalmente, una volta arrivati al punto dove vediamo solo schermo nero con cursore lampeggiante entriamo in modalità testuale con la combinazione di tasti
Codice: [Seleziona]
Ctrl+Alt+F2
Codice: [Seleziona]
inserito username e passwordimpartiamo il comando per effettuare di nuovo gli aggiornamenti quindi:
Codice: [Seleziona]
sudo pacman -Syu
in questo modo il sistema dovrebbe aggiornarsi. Quando gli aggiornamenti sono terminati
riavviamo il PC con:
Codice: [Seleziona]
sudo reboot Se tutto è andato come dovrebbe riavremo il nostro Manjaro funzionante.


Ps. Io ho risolto in questo modo un problema verificatosi su Manjaro Mate, che dopo un aggiornamento di due pacchetti (credo denominati Manjaro keyring ) non dava, al riavvio la schermata di login ma uno schermo nero con cursore lampeggiante.

Pss. La cosa può sembrare banale ma in genere quando vediamo schermo nero ci facciamo prendere dal panico, mentre la soluzione può essere veloce e indolore.(se abbiamo fortuna. -------------------------------perchè ci vuole anche quella)
« Ultima modifica: Aprile 12, 2017, 03:03:12 pm da D-BARTO »
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i

grazie, mi ha risolto lo schermo nero che è vero mi aveva messo in panico.
Dimmi se posso proseguire qui o aprire un altro post
Alla fine di un corposo lavoro di aggiornamento mi da errore:
impossibile eseguire l'operazione richiesta (file di conflitto)
xorg-server: /usr/lib/xorg/modules/extensions/libglx.so   già presente
si sono verificati degli errori nessun pacchetto aggiornato.
riprova...
io riavvio, lo schermo nero non c'è più,
posso fare gli aggiornamenti?

grazie
Kernel: 4.4.59-1-MANJARO x86_64| Xfce 4.12.3 | Manjaro Linux | ASRock model: H110M-HDV |  UEFI | Dual core Intel Core i3-6100| 16 Gb Ram | Intel HD Graphics 530 | X.Org 1.19.3 1680x1050@59.88hz

grazie, mi ha risolto lo schermo nero che è vero mi aveva messo in panico.
Dimmi se posso proseguire qui o aprire un altro post
Alla fine di un corposo lavoro di aggiornamento mi da errore:
impossibile eseguire l'operazione richiesta (file di conflitto)
xorg-server: /usr/lib/xorg/modules/extensions/libglx.so   già presente
si sono verificati degli errori nessun pacchetto aggiornato.
riprova...
io riavvio, lo schermo nero non c'è più,
posso fare gli aggiornamenti?

grazie


Salve! Dato che, da quello che dice, il pc si avvia normalmente, è utile eliminare il pacchetto che ha citato, il quale le crea conflitti con gli altri pacchetti appunto, e di conseguenza gli aggiornamenti non proseguono.

In ogni caso, prima di procedere come le ho scritto, provi a dare da terminale

Codice: [Seleziona]
sudo pacman-mirrors -g
e poi

Codice: [Seleziona]
sudo pacman -Syu
per vedere se il problema si è risolto da sé.
« Ultima modifica: Aprile 07, 2017, 06:07:16 pm da Cavecan3m »
- Vaio-SVE1513C1EW - Scheda grafica AMD/ATI Radeon 7550M/7570M/7650M - Intel Pentium 2020M @ 2x 2.4GHz - 4 gb di RAM - SSD SanDisk 240gb - Xubuntu 16.04 LTS - Manjaro 17 LTS

D-BARTO

  • ****
  • 384
  • Rolling User
Citazione
lo schermo nero non c'è più,
Se hai seguito il mio primo post hai già dato i comandi  per aggiornare quindi non dovresti avere più nessun problema.
-------------------------------------------------------------------------------------
Se il conflitto è rimasto ha ragione Cavecan3m per risolvere devi rimuovere il file incriminato quindi dai questi comandi nel terminale.
Codice: [Seleziona]
sudo rm /usr/lib/xorg/modules/extensions/libglx.soe dopo ridai
Codice: [Seleziona]
sudo pacman -Syue dovresti risolvere anche quel  problema.

Che Manjaro hai installato? (xfce,kde,mate).

Ps. MammaSilvana Mi sono permesso di darti del tu sul Forum siamo tutti giovani e senza titoli.

« Ultima modifica: Aprile 07, 2017, 07:10:47 pm da D-BARTO »
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i

datemi del tu, lo do anche io a voi... ;)

ottimo ho risolto eliminando il pacchetto  che faceva conflitto.
Aggiornamenti eseguiti
Una cosa che devo ancora imparare, il file non potevo cancellarlo dove l'ho trovato, ma da terminale si..devo ancora studiare...

ps. uso manjaro fxce, cosa altro devo mettere in firma che possa aiutare in caso di bisogno?
Kernel: 4.4.59-1-MANJARO x86_64| Xfce 4.12.3 | Manjaro Linux | ASRock model: H110M-HDV |  UEFI | Dual core Intel Core i3-6100| 16 Gb Ram | Intel HD Graphics 530 | X.Org 1.19.3 1680x1050@59.88hz

max deal

  • *****
  • 653
  • The dark side of the moon
Nella firma può essere utile anche l'hardware del pc,quantomeno processore ,ram e scheda video. :)
Un augurio di una vita serena e tranquilla.

manjaro xfce 32 bit e 64 bit

D-BARTO

  • ****
  • 384
  • Rolling User
Una cosa che devo ancora imparare, il file non potevo cancellarlo dove l'ho trovato, ma da terminale si..devo ancora studiare...
No potresti cancellarlo anche seguendo il percorso, ma può risultare macchinoso e lungo, mentre se sai il comando, appena devi fare un rimuovi non vai a cercare nei meandri del sistema ma con un semplice passaggio risolvi.
Anche io stò studiando per abituarmi alla cosa, l'importante è cominciare poi pian piano si va, non sempre si riesce, ma quando questo avviene la soddisfazione è grande.
Citazione
ps. uso manjaro xfce, cosa altro devo mettere in firma che possa aiutare in caso di bisogno?

Concordo con max deal [distribuzione( manjaro xfce)], processore (intel i3 ) , quantità ram, [scheda video(nvidia,ati,o intel)] anche se non è fondamentale ma consigliato.
Per agevolare chi risponde, almeno sa già di che sistema stiamo parlando e su che macchina.
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i

vema

Si dovrebbe avviare in tty2 la domanda è : ma la connessione è attiva?

D-BARTO

  • ****
  • 384
  • Rolling User
Si la connessione è attiva.
Sul mio portatile con wifi e su quello di mammaSilvana  la cosa ha funzionato quindi la connessione è attiva.
In pratica Manjaro si è avviato in tutto e per tutto è solo la parte grafica che non so per quale motivo non funzionava.
Poi nel titolo ho messo "spesso risolve" non è detto, che se si verificano altri problemi, questi possano essere risolti con il metodo proposto.
« Ultima modifica: Aprile 12, 2017, 11:18:27 pm da D-BARTO »
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i

Re:Schermo Nero all’Avvio –Utilizzare la Modalità Testuale(tty) spesso risolve.
« Risposta #9 il: Settembre 11, 2017, 03:51:45 pm »
a me è successo qualcosa di simile.
Dopo l'upgrade avevo blank screen e crisi di panico.
Sono andato in tty e da linea di comando ho lanciato startx.
Veniva fuori un messaggio di errore del tipo no screens found e mi consigliava di andare a dare un'occhiata al file Xorg.0.log.
Al suo interno ho letto Screen(s) found, but none have a usable configuration. Ho provato a spostare il file di configurazione di X
mv /etc/X11/xorg.conf.d/90-mhwd.conf /etc/X11/xorg.conf.d/90-mhwd.confBU
e startx ha funzionato.