Manjaro Linux -Forum Italiano-

problemi con grub

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

problemi con grub
« il: Agosto 17, 2017, 03:39:11 pm »
Ho diverse partizioni in cui sono installate diverse distribuzioni fra cui manjaro. A parte il " normale" problema  del grub di altre distro a far partire manjaro, ora ho uno strano problema con il grub di manjaro. Ultimamente ho dovuto reinstallare manjaro perch il grub mi si era incasinato perch pur installandolo ed aggiornandolo correttamente, all'avvio la schermata del grub dove scegliere i vari sistemi mi appariva dopo tempi biblici. E non avevo idea di come poter sistemare la cosa. Se invece impostavo il grub di altre distro non avevo nessun problema. Dopo aver reinstallto il  grub per un po' ha funzionato a dovere, ma da qualche giorno ha di nuovo lo stesso problema: la schermata del grub appare dopo diversi secondi e non subito. Qualcuno ha idea di cosa bisogna andare a settare per far apparire subito la schermata?Uso linux da parecchio tempo ed in diverse salse, ma una cosa del genere non mi mai capitata e mai ne ho sentito parlare.

Cubanpit

  • *****
  • 1461
    • GitHub
Re:problemi con grub
« Risposta #1 il: Agosto 17, 2017, 11:55:09 pm »
Online non ho trovato molto, la prima soluzione che mi viene in mente di utilizzare il bootloader di un'altra distribuzione adattandolo a Manjaro seguendo questa guida.
Per capire il problema di Manjaro puoi provare a leggere bene i messaggi di installazione e aggiornamento di GRUB quando esegui manualmente queste operazioni (grub-install e update-grub sono i comandi, il primo ha bisogno di qualche opzione che puoi trovare online per essere usato), magari compaiono degli errori o noti comportamenti strani.

Re:problemi con grub
« Risposta #2 il: Agosto 18, 2017, 11:54:14 am »
Online non ho trovato molto, la prima soluzione che mi viene in mente di utilizzare il bootloader di un'altra distribuzione adattandolo a Manjaro seguendo questa guida.
Per capire il problema di Manjaro puoi provare a leggere bene i messaggi di installazione e aggiornamento di GRUB quando esegui manualmente queste operazioni (grub-install e update-grub sono i comandi, il primo ha bisogno di qualche opzione che puoi trovare online per essere usato), magari compaiono degli errori o noti comportamenti strani.
purtroppo anche io non ho trovato nulla a riguardo tranne un utente che aveva antergos che aveva il medesimo problema. Il fatto che lui ha risolto senza fare nulla. Credo che il problema abbia a che fare con le distro che vanno a formattare la swap quando vengono installate. l'unica cosa che posso collegare al mio problema dato che ne ho installate due che mi hanno scassato il boot delle distro perch non trovavano pi l'uuid giusto. Per anche sistemandoi vari "casini" quando vado ad impostare il grub di manaro mi trovo questo problema. Non ho voglia di andare a mettere il grub di altre distro perch dovrei andare a settarle tutte e mi scoccia.  Per fortuna  questione di aspettare solo qualche manciata di secondo per vedere il menu. Per se la cosa peggiora mi tocca eliminare manjaro se non trovo una soluzione.
ps che il problema stia nella configurazione di grub?  Ho modificato la riga
Citazione
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
togliendo una parte della configurazione che era simile a quella di suse
Citazione
GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/disk/by-uuid/1bdd3b6b-6413-426a-9152-bac9d4fa3a5f splash=silent quiet showopts"
come posso rigenerare la voce originale? la parte resume dovrebbe riguardare l'ibernazione che non ho mai abilitato.
« Ultima modifica: Agosto 18, 2017, 12:51:55 pm da caturen »

Cubanpit

  • *****
  • 1461
    • GitHub
Re:problemi con grub
« Risposta #3 il: Agosto 18, 2017, 11:30:11 pm »
Citazione
come posso rigenerare la voce originale? la parte resume dovrebbe riguardare l'ibernazione che non ho mai abilitato.
Esatto, puoi anche inserirla se vuoi (se l'UUID giusto), anche se non penso cambi molto; invece le opzioni successive magari hanno qualche effetto, puoi provare ad inserirle "runtime" modificando la riga di avvio del kernel dal men di GRUB (basta premere E nella schermata di GRUB e modificare la riga d'interesse).

Re:problemi con grub
« Risposta #4 il: Agosto 20, 2017, 05:57:22 pm »
Citazione
come posso rigenerare la voce originale? la parte resume dovrebbe riguardare l'ibernazione che non ho mai abilitato.
Esatto, puoi anche inserirla se vuoi (se l'UUID giusto), anche se non penso cambi molto; invece le opzioni successive magari hanno qualche effetto, puoi provare ad inserirle "runtime" modificando la riga di avvio del kernel dal men di GRUB (basta premere E nella schermata di GRUB e modificare la riga d'interesse).
bah, ho provato ma non cambia nulla. Pare essere un problema di grub di arch/derivate perch ho provato ad installare antergos su di una partizione di un hd appena formattato ed ha il medesimo problema. Suse, Neon nessun problema  che per si ripresentato quando ho installato devuan. Qui per l'installer mi ha segnalato che qualcosa andato storto. Forse c' un qualche problema con il segmento dell'hd dove va ad installarsi il grub, ma mi sembra strano dato che l'hd era stato appena formattato.