Manjaro Linux -Forum Italiano-

Problemi Aggiornamento Impossibile soddisfare la dipendenza

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

D-BARTO

  • ****
  • 411
  • Rolling User
Problemi Aggiornamento Impossibile soddisfare la dipendenza
« il: Ottobre 01, 2017, 12:03:27 pm »
Ciao a Tutti
Oggi si verificato un problema. quando tento di aggiornare appare il messaggio in oggetto.
Citazione
Predisposizione del trasferimento non riuscita:
impossibile soddisfare le dipendenze:
Impossibile soddisfare la dipendenza 'nvidia-304xx-utils=1:304.134' richiesta da linux44-nvidia-304xx
Questa cosa era gia successa anche su arch e lui da quel momento ha smesso di avviarsi.(perch ho fatto dei casini io).
Adesso su manjaro prima di agire da solo chiedo consigli.
Grazie.
PS. ho provato anche con cleanupdate ma questo si chiude improvvisamente senza alcun risultato.
Manjaro xfce 64
« Ultima modifica: Ottobre 01, 2017, 07:28:22 pm da D-BARTO »
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce   Arch Mate 64 bit
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i

Cubanpit

  • *****
  • 1457
    • GitHub
Re:Problemi Aggiornamento Impossibile soddisfare la dipendenza
« Risposta #1 il: Ottobre 01, 2017, 02:17:14 pm »
Sono disponibili altre versioni dei driver per la tua scheda video?
Quali kernel hai installati al momento?

Citazione
PS. ho provato anche con cleanupdate ma questo si chiude improvvisamente senza alcun risultato.
Devo migliorare le "reazioni" in caso di errori, prossimamente arriver un aggiornamento in merito.  O:-)

D-BARTO

  • ****
  • 411
  • Rolling User
Re:Problemi Aggiornamento Impossibile soddisfare la dipendenza
« Risposta #2 il: Ottobre 01, 2017, 03:33:45 pm »
Il kernel attualmente in uso il 4.4.89
C di peggio oggi ho riavviato il sistema e manjaro non parte arrivo ad una schermata con cursore lampeggaiante.
Riesco ad entare in tty ma il non riesco a fare partire in forma grafica.
Dando il comando per aggiornare mi dice che tutto aggiornato ma non parte.
Ho provato a far partire firefox nonparte dice qualcosa inerente a display mancante.
Adesso sono da altro sistema se ci sono dei comandi per provare a risolvere sono in attesa.

La mia scheda video una nvida vecchia e gli unici driver supportati erano i 304 con i 340 ho solo problemi. 
« Ultima modifica: Ottobre 01, 2017, 03:36:48 pm da D-BARTO »
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce   Arch Mate 64 bit
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i

Cubanpit

  • *****
  • 1457
    • GitHub
Re:Problemi Aggiornamento Impossibile soddisfare la dipendenza
« Risposta #3 il: Ottobre 01, 2017, 04:15:26 pm »
Hai provato con i driver open source nouveau?
Per cercare di identificare i problemi puoi vedere i log del server X, magari si riesce a risolvere modificando le configurazioni di questo.

D-BARTO

  • ****
  • 411
  • Rolling User
Re:[Risolto] Problemi Aggiornamento Impossibile soddisfare la dipendenza
« Risposta #4 il: Ottobre 01, 2017, 06:15:43 pm »
Ho provato al leggere i file log ma non posso.
Mi dice di guardare il file xorg.0.log ma quando tento di aprirlo da tty
Citazione
unable to init server impossibile connettersi  connessione rifiutata (gedit:920) gtk-worning canot open display
.
Ho messo su il kernel 4.9 ma risultato zero da quello che vedo sembra sparita la mia scheda video.
anche lo screenfetch non mi segna pi la scheda.
Ora faccio qualche altro tentativo poi se non sistemo provo a reinstallare.
------------------------------------------------------------------------
Risoltooooooooo sono riuscito a far ripartire il tutto. Cavolo, perch non sapevo di preciso dove mettere le mani.
Sembarava che non accettasse i comandi ma probabile che nella fretta digitassi qualcosa di sbagliato e non ottenevo risultati.
Come prima cosa ho installato come detto il Kernel 4.9.52  che "credo" fosse parte del problema.(il vecchio kernel).
poi ho reinstallato i driver nvidia  304xx e cosa molto importante il file relativo al kernel in uso  linux49-nvidia-304xx.
Adesso sembra tutto ok.
Ora vedo di ricostruire tutti i comandi che ho dato e vedo  postare quelli giusti.
In pratica da tty ho aggiornato il kernel e reinstallato i driver sopra citati.riavviato e magia tornato tutto wow.

Ps. Lo provo ancora per un po prima di metter risolto.

« Ultima modifica: Ottobre 01, 2017, 10:46:24 pm da D-BARTO »
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce   Arch Mate 64 bit
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i

Cubanpit

  • *****
  • 1457
    • GitHub
Re:Problemi Aggiornamento Impossibile soddisfare la dipendenza
« Risposta #5 il: Ottobre 01, 2017, 11:10:43 pm »
Citazione
Mi dice di guardare il file xorg.0.log ma quando tento di aprirlo da tty
Non puoi usare gedit, che un'applicazione con interfaccia grafica, senza avere un server grafico funzionante. Puoi usare solo programmi con interfaccia da terminale, per esempio nano e vim.

Citazione
Ora vedo di ricostruire tutti i comandi che ho dato e vedo  postare quelli giusti.
In pratica da tty ho aggiornato il kernel e reinstallato i driver sopra citati.riavviato e magia tornato tutto wow.
"Tutto bene quel che finisce bene... e l'ultimo chiuda la porta!"
Pu essere che durante un aggiornamento non fosse andata a buon fine la creazione degli initramfs (non sono sicuro che contengano qualcosa legato alla grafica, ma un'idea) oppure la compilazione di moduli con DKMS se viene usato.

D-BARTO

  • ****
  • 411
  • Rolling User
Re:Problemi Aggiornamento Impossibile soddisfare la dipendenza
« Risposta #6 il: Ottobre 03, 2017, 07:19:39 pm »
Citazione
Non puoi usare gedit, che un'applicazione con interfaccia grafica, senza avere un server grafico funzionante. Puoi usare solo programmi con interfaccia da terminale, per esempio nano e vim.
Grazie cubanpit questo lo terro a mente.
Ho dato molti comandi ma queli fondamentali che mi hanno ridato Manjaro sono:
per il Kernel
Codice: [Seleziona]
sudo mhwd-kernel -i linux49 
per i driver video
Codice: [Seleziona]
sudo pacman -Sy nvidia-304xx-utils
sudo pacman -Sy linux49-nvidia-304xx
dopo il riavvio e' tornato tutto.
Resto convinto che il problema principale fosse il kernel.

PS. E' sempre un po complicato scrivere i comandi a mano e poi ricopiarli nel terminale. Ci vogliono due pc  di cui uno funzionante per vedere le varie soluzioni. (e non ne avevo due sottomano al momento).
I wiki sono fondamentali grazie a tutti coloro che li creano. ;) ;)
« Ultima modifica: Ottobre 03, 2017, 07:27:11 pm da D-BARTO »
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce   Arch Mate 64 bit
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i