Manjaro Linux -Forum Italiano-

Cpu oltre 100% con Palemoon

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Cpu oltre 100% con Palemoon
« il: Marzo 19, 2017, 06:48:33 pm »
Salve ragazzi, successa una cosa strana. Mentre guardavo un film in streaming, la cpu schizzata oltre il 100%. Avendo installato Noscript negli addon, scelgo io quale script far partire all'interno di un sito non sicuro. In ogni caso questa cosa durata all'incirca 10/15 minuti e poi ritornata bassa, intorno al 20%. Cosa posso fare? Grazie :D
« Ultima modifica: Marzo 19, 2017, 06:52:06 pm da Cavecan3m »
- Vaio-SVE1513C1EW - Scheda grafica AMD/ATI Radeon 7550M/7570M/7650M - Intel Pentium 2020M @ 2x 2.4GHz - 4 gb di RAM - SSD SanDisk 240gb - Xubuntu 16.04 LTS - Manjaro 17 LTS

andy2

  • *****
  • 225
Re:Cpu oltre 100% con Palemoon
« Risposta #1 il: Marzo 20, 2017, 09:50:30 am »
Ma te lo fa sempre o un caso?
Nelle opzioni, hai provato ad usare le MSE (che mi pare dalla prossima versione dovrebbe essere predefinito).

Re:Cpu oltre 100% con Palemoon
« Risposta #2 il: Marzo 20, 2017, 10:50:55 am »
Ciao andy2. una situazione che ho notato da un paio di giorni, anche con youtube. Ieri ha dato il meglio di s, raggiungendo il 120%. QUesto mi accadeva con firefox, per questo ho deciso di cambiare browser installando Palemoon. Sono gi attive le MSE; a questo punto potrei disattivare adobe flash oppure serve anche quello? Secondo me adobe che mi fa schizzare la cpu alle stelle.

P.s. Ho disinstallato adobe flashplugin,  utilizzando solo gli MSE, ma la situazione non cambiata.

« Ultima modifica: Marzo 20, 2017, 11:50:28 am da Cavecan3m »
- Vaio-SVE1513C1EW - Scheda grafica AMD/ATI Radeon 7550M/7570M/7650M - Intel Pentium 2020M @ 2x 2.4GHz - 4 gb di RAM - SSD SanDisk 240gb - Xubuntu 16.04 LTS - Manjaro 17 LTS

andy2

  • *****
  • 225
Re:Cpu oltre 100% con Palemoon
« Risposta #3 il: Marzo 20, 2017, 12:52:38 pm »
Hai provato ad utilizzare un altro browser, tipo Opera o Chromium? Firefox Nightly?
I video sono in html5 o in flash?
Comunque, se prima non te lo faceva, l'unica cosa che mi viene in mente qualche cosa aggiornata di recente; magari il driver della scheda video?

P.S. Magari prova a disattivare MSE e vedi se cambia qualcosa.

Re:Cpu oltre 100% con Palemoon
« Risposta #4 il: Marzo 20, 2017, 10:14:01 pm »
Ho provato ad installare qupzilla, midori e chromium ma nulla. Mi succede sia con video flash che html5, pur disattivando MSE. Come faccio a vederlo e nel caso ad aggiornarlo?
- Vaio-SVE1513C1EW - Scheda grafica AMD/ATI Radeon 7550M/7570M/7650M - Intel Pentium 2020M @ 2x 2.4GHz - 4 gb di RAM - SSD SanDisk 240gb - Xubuntu 16.04 LTS - Manjaro 17 LTS

andy2

  • *****
  • 225
Re:Cpu oltre 100% con Palemoon
« Risposta #5 il: Marzo 21, 2017, 08:29:15 am »
Che scheda video hai e quali driver stai usando?
Magari potrebbe essere che in un prossimo aggiornamento risolvano, altrimenti dovresti provare a downgradare qualcosa per tornare a quando tutto ti funzionava senza problemi.
Visto che cambiando i browser il problema permane, sarei propenso a dire che il problema proprio o del driver video o delle librerie per il playback dei video.
Ah, ma se lo stesso video lo scarichi e lo visualizzi con un normale player, tipo Videolan, non ci sono problemi, giusto?

Re:Cpu oltre 100% con Palemoon
« Risposta #6 il: Marzo 21, 2017, 05:42:13 pm »
Come precisato in un'altra discussione, ho formattato il pc da zero perch avevo urgenza di utilizzarlo. In ogni caso ecco i risultati:

Codice: [Seleziona]
lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7550M/7570M/7650M]

Come faccio a vedere che driver uso?
- Vaio-SVE1513C1EW - Scheda grafica AMD/ATI Radeon 7550M/7570M/7650M - Intel Pentium 2020M @ 2x 2.4GHz - 4 gb di RAM - SSD SanDisk 240gb - Xubuntu 16.04 LTS - Manjaro 17 LTS

D-BARTO

  • ****
  • 408
  • Rolling User
Re:Cpu oltre 100% con Palemoon
« Risposta #7 il: Marzo 21, 2017, 06:07:36 pm »
Prova a dare questo comando:
Codice: [Seleziona]
inxi -G
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce   Arch Mate 64 bit
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i

Re:Cpu oltre 100% con Palemoon
« Risposta #8 il: Marzo 21, 2017, 06:12:30 pm »
Ecco il risultato:

Codice: [Seleziona]
inxi -G
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Thames [Radeon HD 7550M/7570M/7650M]
           Display Server: X.Org 1.19.2 driver: radeon
           Resolution: 1366x768@59.96hz
           GLX Renderer: Gallium 0.4 on AMD TURKS (DRM 2.48.0 / 4.9.15-1-MANJARO, LLVM 3.9.1)
           GLX Version: 3.0 Mesa 17.0.1
- Vaio-SVE1513C1EW - Scheda grafica AMD/ATI Radeon 7550M/7570M/7650M - Intel Pentium 2020M @ 2x 2.4GHz - 4 gb di RAM - SSD SanDisk 240gb - Xubuntu 16.04 LTS - Manjaro 17 LTS

D-BARTO

  • ****
  • 408
  • Rolling User
Re:Cpu oltre 100% con Palemoon
« Risposta #9 il: Marzo 21, 2017, 06:19:05 pm »
Per le ati non so se esisstono driver propietari
Prova ad andare in Manjaro setting manager e verifica in "Configurazione Hardware" se hai qualche indicazione in proposito.
Penso dunque sono acceso  :)
Rolling User: Manjaro 64 bit Mate,Xfce  -- PCLinuxOS 64 bit Mate,Xfce   Arch Mate 64 bit
---------------------------------------------------------------
E5200 dual core 2.5 ghz-4 gbram-Nvidia GeForce 7100 / nForce 620i

Re:Cpu oltre 100% con Palemoon
« Risposta #10 il: Marzo 21, 2017, 09:21:56 pm »
Pur avendo fatto la formattazione, la situazione sempre la stessa. Riguardo a cosa downgradare, cosa mi consiglieresti? Non vorrei fare ulteriori danni  :P Comunque si, i video su pc li fa vedere senza problemi.

Ci che utlizzano i video su youtube:
Codice: [Seleziona]
video/mp4; codecs="avc1.42001E, mp4a.40.2"

 
« Ultima modifica: Marzo 21, 2017, 10:52:18 pm da Cavecan3m »
- Vaio-SVE1513C1EW - Scheda grafica AMD/ATI Radeon 7550M/7570M/7650M - Intel Pentium 2020M @ 2x 2.4GHz - 4 gb di RAM - SSD SanDisk 240gb - Xubuntu 16.04 LTS - Manjaro 17 LTS

Cubanpit

  • *****
  • 1455
    • GitHub
Re:Cpu oltre 100% con Palemoon
« Risposta #11 il: Marzo 21, 2017, 11:49:38 pm »
Ti sconsiglio di installare i driver proprietari AMD, sono un inferno per vari motivi (per esempio non supportano la versione corrente di Xorg).
Cerca di tenere d'occhio l'utilizzo della CPU e vedi se dovuto solo e soltanto al browser o no, prova con video offline e vedi se ogni tanto lo fa ugualmente, controlla le temperature, prova a guardare video su diverse piattaforme (YouTube, Vimeo, ehm ehm) per capire se il problema dovuto al formato e al player utilizzati dalla pagina oppure no.

andy2

  • *****
  • 225
Re:Cpu oltre 100% con Palemoon
« Risposta #12 il: Marzo 22, 2017, 10:03:46 am »
Il fatto che se a lui qualche settimana (mese?) fa funzionava tutto senza problemi, di sicuro qualcosa che a che fare con gli ultimi aggiornamenti.
Qualcosa che riguarda il sottosistema di playback video; ora non ho approfondito ma mi pare che i browser usino anche gstreamer, e questo pacchetto di recente ha avuto un upgrade "importante".

Re:Cpu oltre 100% con Palemoon
« Risposta #13 il: Marzo 22, 2017, 10:20:50 am »
Ti sconsiglio di installare i driver proprietari AMD, sono un inferno per vari motivi (per esempio non supportano la versione corrente di Xorg).
Cerca di tenere d'occhio l'utilizzo della CPU e vedi se dovuto solo e soltanto al browser o no, prova con video offline e vedi se ogni tanto lo fa ugualmente, controlla le temperature, prova a guardare video su diverse piattaforme (YouTube, Vimeo, ehm ehm) per capire se il problema dovuto al formato e al player utilizzati dalla pagina oppure no.

Si infatti provando i driver proprietari mi sono trovato male. Detto ci, ho provato a riprodurre con il software Parole e la cpu stava intorno al 15%. Poi, su palemoon, ho dato spazio ad altri siti di riproduzione video quali Vimeo, Deezer, ma la situazione non cambia. Addirittura ho notato che quando apro roba come Google drive, nel lasso di tempo che passa da una pagina ad un'altra,  schizza al 100%. All'aprtura di palemoon sta intorno al 50/60%. A questo punto non so cosa pensare.

Il fatto che se a lui qualche settimana (mese?) fa funzionava tutto senza problemi, di sicuro qualcosa che a che fare con gli ultimi aggiornamenti.
Qualcosa che riguarda il sottosistema di playback video; ora non ho approfondito ma mi pare che i browser usino anche gstreamer, e questo pacchetto di recente ha avuto un upgrade "importante".

Secondo te cosa potrei fare?
« Ultima modifica: Marzo 22, 2017, 10:30:02 am da Cavecan3m »
- Vaio-SVE1513C1EW - Scheda grafica AMD/ATI Radeon 7550M/7570M/7650M - Intel Pentium 2020M @ 2x 2.4GHz - 4 gb di RAM - SSD SanDisk 240gb - Xubuntu 16.04 LTS - Manjaro 17 LTS

andy2

  • *****
  • 225
Re:Cpu oltre 100% con Palemoon
« Risposta #14 il: Marzo 22, 2017, 11:42:51 pm »
Prova a scaricare una live vecchia e vedi come ti gira, tanto per capire se il problema proprio l'aggiornamento software, altrimenti devi provare col downgrade di qualcosa, ma l vai a tentativi purtroppo; magari come primo tentativo inizierei proprio col downgrade del driver video, poi non so, magari gstreamer e magari lo stesso X.